Vuejs-Vue qriously: vue-qriously - A Vue.js 2 component to draw QR codes on an HTML Canvas using qrious.

[DEPRECATED] vue-qriously

This package is no longer maintained. A Vue.js 2 component to draw QR codes on an HTML Canvas using qrious.

Installation

  • NPM / Yarn

    Run npm install --save vue-qriously, or yarn add vue-qriously

  • With Modules

    // ES6
    import Vue from 'vue'
    import VueQriously from 'vue-qriously'
    Vue.use(VueQriously)
    
    // ES5
    var Vue = require('vue')
    Vue.use(require('vue-qriously').default)
  • <script> Include

    Just include ./dist/vue-qriously.js after Vue itself.

Usage

There's nothing you need to do in JavaScript except for installation. To use the plugin, simply use the qriously component.

<qriously value="Hello World!" :size="200" />

You may use all of these props to change the format of your QR code.

License

MIT

Comments

  • Bump no-case from 2.3.1 to 2.3.2
    Bump no-case from 2.3.1 to 2.3.2

    Feb 6, 2020

    Bumps no-case from 2.3.1 to 2.3.2.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Bump lodash from 4.17.4 to 4.17.15
    Bump lodash from 4.17.4 to 4.17.15

    Feb 6, 2020

    Bumps lodash from 4.17.4 to 4.17.15.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Bump extend from 3.0.1 to 3.0.2
    Bump extend from 3.0.1 to 3.0.2

    Feb 6, 2020

    Bumps extend from 3.0.1 to 3.0.2.

    Changelog

    Sourced from extend's changelog.

    3.0.2 / 2018-07-19

    • [Fix] Prevent merging __proto__ property (#48)
    • [Dev Deps] update eslint, @ljharb/eslint-config, tape
    • [Tests] up to node v10.7, v9.11, v8.11, v7.10, v6.14, v4.9; use nvm install-latest-npm
    Commits
    • 8d106d2 v3.0.2
    • e97091f [Dev Deps] update tape
    • e841aac [Tests] up to node v10.7
    • 0e68e71 [Fix] Prevent merging proto property
    • a689700 Only apps should have lockfiles
    • f13c1c4 [Dev Deps] update eslint, @ljharb/eslint-config, tape
    • f3570fe [Tests] up to node v10.0, v9.11, v8.11, v7.10, v6.14, v4.9; use...
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Bump lodash.mergewith from 4.6.0 to 4.6.2
    Bump lodash.mergewith from 4.6.0 to 4.6.2

    Feb 6, 2020

    Bumps lodash.mergewith from 4.6.0 to 4.6.2.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Bump debug from 2.6.8 to 2.6.9
    Bump debug from 2.6.8 to 2.6.9

    Feb 6, 2020

    Bumps debug from 2.6.8 to 2.6.9.

    Release notes

    Sourced from debug's releases.

    2.6.9

    Patches

    • Remove ReDoS regexp in %o formatter: #504

    Credits

    Huge thanks to @​zhuangya for their help!

    Changelog

    Sourced from debug's changelog.

    2.6.9 / 2017-09-22

    • remove ReDoS regexp in %o formatter (#504)
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Bump sshpk from 1.13.1 to 1.16.1
    Bump sshpk from 1.13.1 to 1.16.1

    Feb 6, 2020

    Bumps sshpk from 1.13.1 to 1.16.1.

    Release notes

    Sourced from sshpk's releases.

    v1.16.1

    • Fixes for #60 (correctly encoding certificates with expiry dates >=2050), #62 (accepting PKCS#8 EC private keys with missing public key parts)

    v1.16.0

    • Add support for SPKI fingerprints, PuTTY PPK format (public-key only for now), PKCS#8 PBKDF2 encrypted private keys
    • Fix for #48

    v1.15.2

    • New API for accessing x509 extensions in certificates
    • Fixes for #52, #50

    v1.14.1

    • Remove all remaining usage of jodid25519 (abandoned dep)
    • Add support for DNSSEC key format
    • Add support for Ed25519 keys in PEM format (according to draft-curdle-pkix)
    • Fixes for X.509 encoding issues (asn.1 NULLs in RSA certs, cert string type mangling)
    • Performance issues parsing long SSH public keys
    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    Reply
  • Upgrade rollup
    Upgrade rollup

    Feb 26, 2020

                                                                                                                                                                                                           
    Reply
  • 修复打包时出现`Unexpected token punc «}», expected punc «:» `的错误
    修复打包时出现`Unexpected token punc «}», expected punc «:» `的错误

    May 6, 2017

    您好,最近在项目中使用了您的vue-qriously组件,但是在项目打包时遇到了问题,参考了其他类似代码后做了下修改,希望可以采纳,打扰了:)

    Reply
  • Keep getting this error
    Keep getting this error

    Nov 29, 2017

    screen shot 2017-11-29 at 21 11 45

    Reply
  • the qr not in the center of canvas
    the qr not in the center of canvas

    Aug 10, 2017

    if i have set the "padding" , the qr will not in the center, the right will be more than left. use like this: <qriously value="https://github.com" :size="200" :padding="15"></qriously>

    wontfix 
    Reply
  • error import the module, does it lack a index.js file in the main folder
    error import the module, does it lack a index.js file in the main folder

    Jul 1, 2017

    is there necessary a index.js file in the main folder import module image error message image lack the index.js file in the main folder image

    Reply
  • 生成的二维码没有铺满整个canvas
    生成的二维码没有铺满整个canvas

    May 9, 2018

    image

    invalid 
    Reply
  • 背景色不显示,backgroundAlpha属性默认为0
    背景色不显示,backgroundAlpha属性默认为0

    Jul 3, 2018

    希望作者能把属性写全一些,设置背景色无效果,以为是bug呢,看了组件才知道默认透明度是0。。。 backgroundAlpha设置为1就好了

    invalid 
    Reply
  • how to make this canvas exchange to img
    how to make this canvas exchange to img

    Apr 12, 2018

    i think u can create type let user select img and anvas.

    invalid question wontfix 
    Reply
  • Build script is broken
    Build script is broken

    Feb 25, 2020

    Trying to run npm run build yields:

    🚨   (vue plugin) Unknown transform 'collections'
    

    This is probably due to updates in vue and the rest of the build tooling.

    This package is nearing the end of its lifetime. The original package qrious seems to be dead as well https://github.com/neocotic/qrious/issues/121.

    bug help wanted wontfix 
    Reply
  • When backgroundAlpha is 0.0, the image saved on Chrome can't be scanned in some programs like wechat.
    When backgroundAlpha is 0.0, the image saved on Chrome can't be scanned in some programs like wechat.

    Feb 24, 2020

    The default backgroundAlpha of vue-qriously is 0.0, but qriously default backgroundAlpha is 1.0. I think it's better to set backgroundAlpha to 1.0 as default.

    bug help wanted wontfix 
    Reply
  • Plugin bricks UglifyJs
    Plugin bricks UglifyJs

    Jun 23, 2017

    image

    Reply